|
 
logo
|
|

Vous etes ici -Home : les nouvelles du site


page10

Pratique : La fonction =SI ( test_logique; valeur_si_vraie ; valeur_si_faux)

Parmi les fonctions excel, il existe des fonctions logiques ( Dans Catégories de fonctions, choisir Fonctions logiques) et parmi celles-ci la fonction =SI ().

La fonction =SI renvoie une valeur différente en fonction d’un test fait sur le contenu d’une cellule :

• le test logique utilise les symboles suivant :
• SI ( A1=”janvier”; ... ) : teste si la cellule A1 contient exactement le mot janvier.
• SI ( A1=120; ... ) : teste si le contenu de la cellule A1 est égale à 120.
• SI ( A1>120; ... ) : teste si le contenu de la cellule A1 est supérieur à 120.
• SI ( A1>=120 ; ...) : teste si le contenu de la cellule A1 est supérieur ou égal à 120.
• de la même façon, on utilisera < et <= pour inférieur et inférieur ou égal .

• En fonction du test ci-dessous, il est possible d’afficher des valeurs différentes dans la cellule qui contient la formule en utilisant la syntaxe suivante : =SI ( test_logique; valeur_si_vraie ; valeur_si_faux)



Par exemples, tester les formules dans les cases suivantes:
• en B1 = SI(A1=”janvier” ; “Bonne année”; “Vivement Noël” ) et saisir un mois dans A1
• en B2 =SI(A2>10 ; A2+10 ; A2+4) et saisir un nombre dans A2
• en B3 =SI(A3<=60; “Pensez à acheter des repas “ ; “ il vous reste plus de 4 repas “)

  Réaliser une feuille de calcul permettant d’indiquer si un compte possède un solde positif ou négatif.
 


La forme si imbriquée :

Pour des tests plus compliqués , il est possible d’imbriquer les fonctions SI les unes dans les autres.
Par exemple si on souhaite tester le contenu de deux cellules, en indiquant si elles sont positives ou négatives :

En C2, on saisit:

=SI(A2<0;SI(B2<0;"2 négatifs";"A négatif , B positif");SI(B2<0;"A positif, B négatif";"2 positifs"))

1)si A est négatif, alors si B est négatif, on affiche “2 négatifs” sinon "A négatif , B positif"

2)si A n’est pas négatif, alors si B est négatif, on affiche "A positif, B négatif" sinon "2 positifs"
> << Article Précédent | Article Suivant >> >

par ffred - le 10 mars 2003 -


  • > Pratique : La fonction SI , le 24 mai 2004, par sosia

    je ne sais pas comment lire cette fonction : =si(f12="" ;"" ;i11-g11) répondez le plus vite possible svp. Merci



    • > Pratique : La fonction SI , le 28 mai 2004, par ffred

      Bonsoir.

      Si la case f12 est vide (="") alors la fonction renvoie "" (c’est à dire rien). Sinon, si la case f12 contient quelque chose alors la fonction fait le calcul cases i11-g11.

      Non ?





  • > Pratique : La fonction SI , le 20 janvier 2005, par diouck

    je suis un pur novice dans le logiciel excel mais lorsque j’utilise la fonction "si" mon problème est que je ne peux pas mettre plus de 8 conditions. y a t’il un moyen de pallier a ce problème car j’ai besoin d’environ 9 a 10 conditions pour le calcul ????



    • > Pratique : La fonction SI , le 26 janvier 2005, par ffred

      Bonsoir.

      Peut-être devriez-vous essayer de mettre une partie de vos calculs dans une autre cellule ?

      Par exemple dans une cellule vous faites un si avec 5 conditions, et dans une autre un si avec la condition que la premiere cellule soient vraie et les 4 suivantes ?

      Cela vous aide-t-il ?





    • > Pratique : La fonction SI , le 2 février 2005, par Phitot

      bonjour, voici quelque chose (un peu compliqué certes) qui fonctionne. il s’agit de concatener(avec le caractère "&") les 7 premiers ’SI’aux suivants avec une petite vérif au passage "pas de solution". L’exemple ci-dessous utilise 11 conditions.

      =SI(SI(I8=1 ;"ok1" ;SI(I8=2 ;"ok2" ;SI(I8=3 ;"ok3" ;SI(I8=4 ;"ok4" ;SI(I8=5 ;"ok5" ;SI(I8=6 ;"ok6" ;SI(I8=7 ;"ok7" ;))))))) &SI(I8=8 ;"ok8" ;SI(I8=9 ;"ok9" ;SI(I8=10 ;"ok10" ;SI(I8=11 ;"ok11" ;""))))="" ;"pas de solution" ; SI(I8=1 ;"ok1" ;SI(I8=2 ;"ok2" ;SI(I8=3 ;"ok3" ;SI(I8=4 ;"ok4" ;SI(I8=5 ;"ok5" ;SI(I8=6 ;"ok6" ;SI(I8=7 ;"ok7" ;))))))) &SI(I8=8 ;"ok8" ;SI(I8=9 ;"ok9" ;SI(I8=10 ;"ok10" ;SI(I8=11 ;"ok11" ;"")))))

      Voili voila





    • > Pratique : La fonction SI , le 2 mars 2005, par Olivier Dabazach

      Pour tester plus de deux conditions, je préfère utiliser des valeurs booléennes :

      Rappel : sous Excel VRAI = 1 et FAUX = 0

      Par exemple : si la cellule A5 contient le nombre 5, l’expression A1=5 (VRAI) vaut 1 l’expression A1<>5 (FAUX) vaut 0

      Application (débile) : supposons que l’on souhaite tester un nombre en a5 et afficher dans une cellule 10 si le nombre est inférieur à 100, 50 si le nombre est compris entre 100 et 200, 80 si le nombre est compris entre 200 et 300, 150 si le nombre est supérieur à 300

      Il suffit ( !) d’écrire : =(a5<100)*10 + (a5>=100)*(a5<200)*50 + (a5>=200)*(a5<300)*80 + (a5>=150)*300

      Si A5 contient 250, cette expression sera évaluée comme :

      =(a5<100)*10 + (a5>=100)*(a5<200)*50 + (a5>=200)*(a5<300)*80 + (a5>=150)*300 0 *10 + 1 * 0 *50 + 1 * 1 *80 + 0 *300 = 80 !

      Avec la fonction SI, cela donnerait très vite un plat de spaghetti imbrications... =SI(a5<100 ;10;si(ET(a5>= 100 ;A5<200) ;50... j’ai mal au crâne ici...

      mailto:dabazach@wanadoo.fr





  • > Pratique : La fonction SI , le 9 février 2005

    Bonjour j’aimerai que vous m’aidier en me disant comment on pourait dire si toutes les cellule sont vide de (a35:a40) alors vide sinon un certain calcul merci



    • > Pratique : La fonction SI , le 15 février 2005, par ?????

      Il y a 2 posibilité 1) vous faites si((a1:a40)=0 ;"" ;"votrecalcul") 2) vous faites si((a1&a2&a3&a4&a5)="" ;"" ;"votre calcul") la 2 ° est faite avec des valeurs logique Ces sont dezs exemples adapte les



    • > Pratique : La fonction SI , le 18 août 2005

      Mes respects...

      Utilise la fonction NBVAL() par exemple





  • > Pratique : La fonction SI , le 19 avril 2005, par isablème

    Bonjour ! Comment libeller la syntaxe d’un test_logique selon lequel une cellule contient un mot parmi d’autres ? car si le test logique A1="janvier" teste si la cellule A1 contient EXACTEMENT le mot janvier SI(A1 = "*janvier*" ; …) devrait tester si la cellule A1 contient le mot janvier même s’il est inclus dans une chaîne de caractères, hors ça ne fonctionne pas ! j’ai tenté de remplacer le signe = par un autre opérateur mathématique, et aussi d’exprimer autrement la notion de chaîne de texte, d’inverser les termes du test : « janvier »∑A1, mais Excel m’ignore… Merci par avance si vous me sortez de là



    • > Pratique : La fonction SI , le 11 août 2005

      Alors, je ne connais pas exactement la "belle" réponse, mais tu peux essayer ceci :

      =cherche("janvier" ;A1) (recherche une chaîne de caractères à l’intérieur d’une autre et renvoie sa position).

      Donc, si la chaîne de caractère est dans le mot, tu recevras en réponse un entier, si par contre la réponse est une erreur (#value !), cela veut dire que le mot ne contient pas la chaîne.

      PS : find() in English





  • Pratique : La fonction SI , le 5 mai 2007, par FRJA1843

    Bonjour, quels sont les codes de couleurs a utiliser pour mettre en couleur une cellule quand le test est VRAI ? Merci

    Jacques





    • Pratique : La fonction SI , le 8 mai 2007, par andre

      Voila

      Bonjour a tous et deja merci pour votre aide

      Je souhaite faire par exemple une facture mais afin d’éviter d’encoder a chaque fois els reference clients et produits est il possible d’encoder "automatiquement" le nom prenom adresse ect... d’un client et la denomination et prix d’un produits. Si on encode juste dans une cellule une reference par exemple.

      Un ami m’a parle de la fonction SI mais je n’y connis pas grand chose.

      Merci de m’aider.





      • Pratique : La fonction SI , le 18 mai 2007, par Maffre

        Bonjour, Je pencherai plutôt pour la rechercheV, qui relie un tableau de données à une facture ou autre document simplement grâce à un code.Il faut faire un tableau sur une autre feuille du classeur excel et utiliser cette fonction en incluant la fonction SI pour améliorer la présentation...



    • Pratique : La fonction SI , le 25 mai 2007, par safaa

      EXPLIQUER MOI LA FONCTION SI ET LA FONCTION SOMME SI SVP MERCI



      • Pratique : La fonction SI , le 25 mai 2007, par safaa

        bonjour donner moi svp un exemple de la fonction recherche H et recherche V merci bien



        • Pratique : La fonction SI , le 14 novembre 2007, par Naïs

          J’ai effectué le test logique suivant =SI(C40="max" ;"ok" ;"erreur") Mon problème est que quand il n’y a rien ou 0 dans la case C40, le test est fait comme si c’était vrai, alors qu’il devrait être faux ! Comment faire prendre en compte la valeur 0 ?

          Merci de me répondre






          |
          | |
          Respecter le droit d'auteur.
          In f(x) Venenum © 2001-2010 réalisation et conception : Frederic Ferre, avec tous nos remerciements à l'équipe de SPIP.
          Informations sur le Copyright-images-conception